Cuda error in file 'CHHashTypePlain.cpp' in line 232

Discussion and support for the CUDA Multiforcers (Windows and Linux)
  • Ads

Cuda error in file 'CHHashTypePlain.cpp' in line 232

Postby the_mentor » Sat Jun 09, 2012 4:40 am

I have a machine running ubuntu 12.04
when i run Cryptohaze-Multiforcer 1.31a i get the following error

Cuda error in file 'CHHashTypePlain.cpp' in line 232 : out of memory.
and then the program crashes.
here is my video card info.



CL_DEVICE_NAME: NVS 4200M
CL_DEVICE_VENDOR: NVIDIA Corporation
CL_DEVICE_AVAILABLE: Yes
CL_DEVICE_MAX_COMPUTE_UNITS: 1
CL_DEVICE_TYPE: CL_DEVICE_TYPE_GPU
CL_DEVICE_MAX_CLOCK_FREQUENCY: 1480 MHz
CL_DEVICE_GLOBAL_MEM_SIZE: 511 MB
CL_DEVICE_LOCAL_MEM_SIZE: 48 KB
CL_DEVICE_LOCAL_MEM_TYPE: CL_LOCAL
CL_DEVICE_MAX_CONSTANT_BUFFER_SIZE: 64 KB
CL_PLATFORM_NAME: NVIDIA CUDA
CL_PLATFORM_VENDOR: NVIDIA Corporation
CL_PLATFORM_VERSION: OpenCL 1.1 CUDA 4.2.1

thanks tour all the help!!
the_mentor
 
Posts: 7
Joined: Sat Jun 09, 2012 4:35 am

Re: Cuda error in file 'CHHashTypePlain.cpp' in line 232

Postby Bitweasil » Sat Jun 09, 2012 5:58 am

What hash type?
Bitweasil
Site Admin
 
Posts: 912
Joined: Tue Jan 20, 2009 4:26 pm

Re: Cuda error in file 'CHHashTypePlain.cpp' in line 232

Postby the_mentor » Sat Jun 09, 2012 6:18 pm

LM
but it happens with NTLM as well
the_mentor
 
Posts: 7
Joined: Sat Jun 09, 2012 4:35 am

Re: Cuda error in file 'CHHashTypePlain.cpp' in line 232

Postby Bitweasil » Sat Jun 09, 2012 7:18 pm

Yep. I know why this is happening. :-/

I made the assumption that all SM_20 cards and beyond had >512MB RAM onboard. Yours doesn't.

What OS are you on? The new multiforcer will work properly, and work with the amount of RAM you have. It's unfortunately Linux only right now.

Otherwise, I can pop out a tweaked release to work around this for you.
Bitweasil
Site Admin
 
Posts: 912
Joined: Tue Jan 20, 2009 4:26 pm

Re: Cuda error in file 'CHHashTypePlain.cpp' in line 232

Postby the_mentor » Sat Jun 09, 2012 9:57 pm

I have Ubuntu 12.04 LTS 64bit
I've also tried the New-Multiforcer
when i try to use that i get the following error:
CHHashFileVPlainLM::OpenHashFile(hash.txt)
CHHashFileVPlainLM::SortHashes()
Cannot add devices!

Thank you very much for your help i really appreciate it!!
the_mentor
 
Posts: 7
Joined: Sat Jun 09, 2012 4:35 am

Re: Cuda error in file 'CHHashTypePlain.cpp' in line 232

Postby Bitweasil » Sat Jun 09, 2012 11:26 pm

Try running the new multiforcer with "--nocpu --noopencl" as parameters - LM is only implemented in CUDA right now, and it will complain like you see otherwise. Still a beta. :)
Bitweasil
Site Admin
 
Posts: 912
Joined: Tue Jan 20, 2009 4:26 pm

Re: Cuda error in file 'CHHashTypePlain.cpp' in line 232

Postby the_mentor » Sun Jun 10, 2012 6:54 pm

this is the errors i get when i try the "--nocpu --noopencl" command switches
CHHashFileVPlainLM::OpenHashFile(hash.txt)
CHHashFileVPlainLM::SortHashes()
CHHashFileVPlainLM::ExportUncrackedHashList()
Error copying passwords from device to host!
err: 4, err2: 4

any ideas?
the_mentor
 
Posts: 7
Joined: Sat Jun 09, 2012 4:35 am

Re: Cuda error in file 'CHHashTypePlain.cpp' in line 232

Postby Bitweasil » Mon Jun 11, 2012 4:41 am

Error 4 is a generic launch failure... :(

Try reinstalling the drivers. It looks like you've got CUDA 4.2 installed, but make sure you're running the latest version.

Next, try running it from a terminal, WITHOUT X running - X can use an absolute ton of memory with new compositing window managers.

ctrl-alt-f1
sudo service gdm stop
./New-Multiforcer ...

It's looking like general out of memory errors, or something weird & driver related.

Try running it with "--debug" and paste the full run. I can build you a custom, ultra-verbose version if that doesn't help. I'd like to track down the errors - laptop users are a definite target for this.
Bitweasil
Site Admin
 
Posts: 912
Joined: Tue Jan 20, 2009 4:26 pm

Re: Cuda error in file 'CHHashTypePlain.cpp' in line 232

Postby the_mentor » Tue Jun 12, 2012 1:39 am

I tried to stop the gdm service but it told me that the service is not available.
I've ran the command in the ctrl+alt+f1 terminal with the debug option and this is the error i've got.

Got 1 CUDA devices!
Got 1 OpenCL GPUs
Got 4 CPU cores
Device 0: CUDA, device 0
Device 1: OpenCL, p:0, d:0
Device 2: CPU, threads: 2
CHHashFileVPlainLM::CHHashFileVPlainLM()
CHHashFileVPlainLM::OpenHashFile(hash.txt)
CHHashFileVPlainLM::SortHashes()
MFND: Setting hash name LM
Cannot add devices!

I think i have the latest driver i've used ubuntu's additional driver wizard to install the drivers.
I will do some more research to see if there is a newer version out there.
the_mentor
 
Posts: 7
Joined: Sat Jun 09, 2012 4:35 am

Re: Cuda error in file 'CHHashTypePlain.cpp' in line 232

Postby Bitweasil » Tue Jun 12, 2012 2:17 am

the_mentor wrote:I think i have the latest driver i've used ubuntu's additional driver wizard to install the drivers.
I will do some more research to see if there is a newer version out there.


Oh, there's likely a MUCH newer version out there... Ubuntu wizards are usually terribly behind. Though 12.04 just came out... might not be terrible. Hrm.

"dmesg | grep NVIDIA" should show you the driver version installed.

It's seeing the device. Just not talking properly, it seems. You will still want to pass "--noopencl --nocpu" to the command line to prevent it from trying to use the CUDA device as an OpenCL device also. That is not supported right now.
Bitweasil
Site Admin
 
Posts: 912
Joined: Tue Jan 20, 2009 4:26 pm

Next

Return to CUDA Multiforcers

Who is online

Users browsing this forum: No registered users and 2 guests

cron